BatteryStore™ v1.5

User Guide
Trademark

C5100 BatteryStore™ is a trademark of Cadex Electronics Inc. All other trademarks or registered trademarks mentioned herein are the property of their respective owners.

Copyright Notice

Copyright © 2015 by Cadex Electronics Inc. All rights reserved. No part of this publication nor the software and/or firmware controlling Cadex product(s) may be reproduced, transmitted, transcribed, stored in a retrieval system, or translated into any language or computer language in any form or by any means without the express written permission of Cadex Electronics Inc.

Revision Rights

Cadex Electronics Inc. reserves the right to revise this publication and make changes in the contents thereof without obligation to notify any person of such changes. Please contact Cadex Electronics Inc. (service@cadex.com) for suggestions or corrections.

Disclaimer

While every effort is made to ensure that the information contained in this manual and Online Help is accurate and up-to-date, Cadex Electronics Inc. does not warrant or guarantee the accuracy of the contents of this manual and Online Help. Further, Cadex makes no warranties, either expressed or implied, as to the merchantability or fitness for a particular purpose of the C5100 BatteryStore Software and/or its documentation.

In no event will Cadex or its officers or employees be responsible for any consequential, incidental, or indirect damages (including damages for loss or business profits, business interruption, and the like) arising out of the use or inability to use the C5100 BatteryStore Software and/or its documentation.

To obtain service, contact service@cadex.com or (Canada) 1-604-231-7777, (USA Toll Free) 800-565-5228, or (Europe) +49 (0) 6105 975 11-0.

Part Number: 89-207-5062
Document Number: PSMAN0084 Rev 3
February 2015
# Table of Contents

**Section 1: Get Started with BatteryStore™** ................................................................. 5  
Welcome to BatteryStore™ ....................................................................................... 5  
The BatteryStore Package ......................................................................................... 7  
Computer Requirements ......................................................................................... 7  
Receipt Printer Compatibility ............................................................................... 7  
Receipt Printer Installation ..................................................................................... 8  
Install BatteryStore ................................................................................................. 9  
Uninstall BatteryStore ........................................................................................... 9  
Software Updates .................................................................................................... 9  
The Menu Bar .......................................................................................................... 10  
Connect a C5100 to the PC .................................................................................... 11  
Connect a C5100 to BatteryStore ......................................................................... 11  
Exit the BatteryStore Application ....................................................................... 11

**Section 2: Test, Cycle and Charge Batteries** ......................................................... 12  
Perform a Battery Test ........................................................................................... 12

**Section 3: Manage Test Results** ....................................................................... 16  
Manage Test Results ............................................................................................. 16  
View Test Results .................................................................................................. 17  
Print Test Results .................................................................................................. 18  
Export Test Results ............................................................................................... 18  
Save Test Results ................................................................................................... 19  
Delete Test Results ............................................................................................... 19  
Search for Test Results ........................................................................................ 20  
Sort the Test Results ............................................................................................. 20  
View a Test Summary Report ............................................................................... 21

**Section 4: Configure BatteryStore™ Options** ................................................... 22  
BatteryStore Options ........................................................................................... 22  
Site Information Setup ......................................................................................... 23  
Printer Setup ......................................................................................................... 25  
Test Report Template ............................................................................................ 26
Section 1: Get Started with BatteryStore™

Welcome to BatteryStore™

BatteryStore™ is a Microsoft Windows-based software that lets users start and monitor battery tests on a C5100 and stores battery test result histories in a database.

BatteryStore can export test data, consolidate tests, provide test reports, and generate performance summaries. BatteryStore also provides the ability to print receipts and to print customized test reports.

Two Methods to use BatteryStore:
1. PC Mode

The PC with BatteryStore is used for:

a. C5100 Control (Test, Charge, or Cycle)
b. Data Management: Store and export test results.
c. PC or Network Printing: Prints a test report.
d. Optional Receipt Printing: Prints test results on a 2.25” [57mm] wide receipt.
How to setup up PC Mode:
1. Connect hardware according to the PC Mode diagram.
2. Configure **BatteryStore** Options (Section 4)
   a. Site information
   b. Printer Setup
   c. Test report template

2. **Standalone Mode**

   ![Diagram of hardware connections]

   The PC with **BatteryStore** is only used for:
   a. Testing (QuickSort 3.0, QuickSort, Charge, and Cycle) via the C5100
   b. Configuring the C5100 (Receipt information, date and time). *(Note: The date & time is lost once the C5100 is powered down.)*
   c. Printing test results on a 2.25” [57mm] wide receipt receipts. The PC does not have to be connected to the C5100 once the device is configured. *(Receipt printer sold separately)*
   d. Upgrading firmware

   How to setup Standalone Mode:
   1. Connect hardware according to the Standalone Mode diagram.
   2. Configure C5100 Setup (Section 5)
      a. Print mode
      b. Receipt printer setup
      c. Date and time
The BatteryStore Package

The **Cadex C5100 BatteryStore** package contains the following items:

- Cadex C5100 **BatteryStore** Software on CD-ROM.
- USB Cable with Type A and B connectors.
- DB9 Male-to-male Adapter (applicable for Receipt printer only)
- This user guide.

Computer Requirements

**BatteryStore** requires the following computer configuration:

- Windows XP or Windows 7 or Windows 8
- 1.2 GHz or faster CPU
- 512 MB RAM
- PC with USB port
- An SVGA color monitor 1024 x 768 or better, 256 colors minimum; mouse & keyboard

Receipt Printer Compatibility

The **C5100** can be configured to print test results on a 2.25” [57mm] wide receipt. The **C5100** and **BatteryStore** are compatible with the **Bixolon STP-103 G** thermal printer (sold separately).
Receipt Printer Installation

The Bixolon STP-103 G thermal printer requires the following installation steps.

1. Connect DB9 Male-to-male Adapter into the C5100 serial port (back of device).

2. Set the DIP switches on the Bixolon STP-103 G thermal printer:
   a. Serial Interface settings
      Baud rate: 9600 bps
      Data bits: 8 bits
      Parity: None
      Stop bit: 1 bit

      The serial interface settings are required in order for the C5100 to correctly communicate with the thermal printer. See figure below for printer underside.

3. Follow the Printer Installation Guide that is included with the Bixolon STP-103 G thermal printer.
Install BatteryStore

To install BatteryStore:

1. Download the software by going to www.cadex.com and clicking on SUPPORT. From the support page click on TECHNICAL SUPPORT More Information. Scroll down and click on BATTERYSTORE™ SOFTWARE. Select the file to download and follow the instructions on your screen.

2. Open the folder where the downloaded file was stored and double-click BatteryStore.msi to install BatteryStore. The Welcome to Cadex BatteryStore Setup Wizard window appears.

3. Follow the steps through the installation wizard.

Uninstall BatteryStore

To remove BatteryStore from your computer:

1. In Control Panel, use Add or Remove Programs.

2. Select Cadex BatteryStore and click Remove.

3. Follow the steps through the uninstall wizard.

Software Updates

To see which version of BatteryStore is installed on the computer, select About from the Help menu. The BatteryStore version appears in the About window.

Update BatteryStore Software

When a new version of BatteryStore becomes available, users can download it from the Cadex website.

The download is a compressed executable file (with file extension .MSI).

Running the downloaded executable will either run Setup and install a new version of the software, or extract files to a specified directory. In the latter case, follow instructions in the ReadMe.Txt file that accompanies the software update before running the executable file that installs the upgrade.
The Menu Bar

**BatteryStore’s Main** window displays a title screen, a menu bar, and a C5100 status bar.

The menu bar on **BatteryStore’s Main** window displays six menus: *File, Test, Results, Options, C5100 Setup, and Help.* Clicking any of these menus displays a list of menu commands.

**File Menu**

The *File* menu contains two items, as follows:
- *Connect:* Establishes communication between C5100 and PC
- *Exit:* Select the *Exit* to close **BatteryStore.**

**Test Menu**

Click *Test* to test a battery on a C5100.

**Results Menu**

Click *Results* to view battery test results.

**Options Menu**

Click *Options* to specify site information, printer setup, report template fields, battery model information, and database maintenance options.

**C5100 Setup Menu**

Click *C5100 Setup* to configure the C5100 hardware, including the receipt printer settings.
Help Menu
The Help menu contains two items, as follows:

Help Content: Click Help Content to view the Help file.
About: Click About to view the About window.

Connect a C5100 to the PC
To connect a C5100 to the PC:
1. Connect one end of the USB cable to the PC.
2. Connect the other end of the USB cable to the backside of the C5100.

Connect a C5100 to BatteryStore

NOTE
BatteryStore automatically connects to a C5100 when BatteryStore starts up.

Select Connect from the File menu to connect a C5100 to BatteryStore. The Connecting to C5100 window appears.

If the connection was successful, the C5100 is listed in the Main window.

Exit the BatteryStore Application
To close the BatteryStore application:
From the File menu, select Exit. The Exit window appears.

Click Yes to exit BatteryStore.
Section 2: Test, Cycle and Charge Batteries

Perform a Battery Test

WARNING
Do not remove the C5100 battery adapter while the C5100 is running a test or updating the firmware.

NOTE
Test results are retained on the C5100 until a new test is initiated. Therefore, additional copies of receipts can be printed without running the test a second time.

The result from a test, cycle, or charge is automatically saved in the Results Section.

To perform a battery test, click the Test menu item. The Battery Test window appears.
Battery Test Methods

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test</td>
<td>Performs rapid battery tests using either Cadex’s QuickSort™ 3.0 or QuickSort™. Classifies batteries into four ranges – Good, Fair, Low, or Poor. Approximately 30 seconds.</td>
</tr>
<tr>
<td>Charge</td>
<td>Charges a battery. Approximately 3 hrs.</td>
</tr>
<tr>
<td>Cycle</td>
<td>Cycles a battery with charge/discharge/charge and displays measured capacity as a percentage of the Q-Code/C-Code capacity rated value. Approximately 7 hrs.</td>
</tr>
</tbody>
</table>

A battery test contains the following steps:

1. Select the battery model or set the user specified rating.
2. Select the battery test.
3. Print the receipt or test report.

**Step 1: Select the Battery Model**

The Battery Test window provides two methods to select a battery model:

a. User Specify Rating: Input the nominal battery capacity mAh in the field (this information should be located on the battery label). Enter manufacturer and model information if desired.

Or

b. Select from Battery Models: Select a battery from the list. If your battery model cannot be located, use Option A.
In the Select from Battery Models option, click Select Battery. The Battery Models window appears.

In the Battery Models window, click the DOWN ARROW in the Manufacturers field to view a list of battery models manufactured by a specific company.

NOTE

You can update the list of battery models by entering new models or downloading an updated database from the Cadex website (see Update and Backup the Battery Models Database).

The Battery Models window lists all available battery models. For each battery model, the window shows the manufacturer’s name, the battery model’s number, the rating, the alias, and the QS3 model if applicable. To set a specific battery model as a “favorite”, select the check box in the Favorite column. To view only those battery models selected as favorites, select the Show Favorites Only check box.

Show QS3 Models Only lists all available QuickSort™ 3.0 (QS3) battery models. For each battery model, the window shows the manufacturer’s name, the battery model’s number, the rating, the alias, and the QS3 model. To view only QS3 battery models, select the Show QS3 Models Only check box.
Step 2: Run a Battery Test, Charge, or Cycle
In the User ID field, type an identification code for a customer or employee. Type any notes in the Service Notes field, as required. To test the battery, click Test. To charge the battery, click Charge. To discharge and then charge the battery, click Cycle.

The Test Status field indicates the status of the test:
- A progress bar is used to show the progress of the current test.
- A Cancel button is used to halt the test.
- Finish: the test has completed.

The Test Log field contains additional information about the test status and test result.

Step 3: Print the Receipt or Test Report
BatteryStore prints receipts on a standalone receipt printer and test reports on a PC printer. Configure the default printer in the Options->Printer Setup window.

1. Standalone Receipt Printer
Go to C5100 Setup to configure receipt printer. (Note: To activate Receipt printing, ensure the C5100 printer is not set to disabled).

2. PC Printer
Go to Options->Printer Setup to configure PC printer.

The Print button prints to the default printer.

The Auto Print Test Report option automatically prints the test report or receipt when the test is completed – you do not need to click Print.
Section 3: Manage Test Results

Manage Test Results

The Test Results window lists all battery test reports. For each test result, the Test Results lists:

- Test number, test type, and test result
- Start and end date & time of test
- Battery manufacturer’s name and battery model
- Fault code, if any.
- Capacity rating, voltage rating, and equipment ID
- C5100 firmware revision number

You can view and print test reports, export a test report to a comma-delimited text file, save the test report as a PDF file, view a summary, or delete the test report.
View Test Results

To view a test result, click the **Results** menu item. The **Test Results** window appears.

Highlight a test result and click **View**. The test result appears in the **Service Report** window.

To print the test report, click **Print**. To save the test report to a file, click **Save**.
Print Test Results

To print a test result, click the Results menu item. The Test Results window appears.

Click the check box in the left-hand column to select a test result and click Print. The report is sent to the default printer. Multiple test reports can be printed by left-clicking multiple test results. Click the Select/deselect all check box to quickly select or deselect all test results.

Export Test Results

To export a test result to file, click the Results menu item. The Test Results window appears.

Select the check box adjacent to each test result to export and click Export. The Export Report Data window appears.

In the File Name field, type a name for the report and click Save. The report may be saved with an Excel format (.xls) or comma separated value format (.csv).
Save Test Results

To save a test result, click the Results menu item. The Test Results window appears.

Select the check box adjacent to the test result to save and click Save As. The Report Save As window appears.

In the File Name field, type a name for the report and click Save. The test result report may be saved in PDF, HTML, and text file formats.

Delete Test Results

To delete a test result, click the Results menu item. The Test Results window appears.

Select the check box adjacent to test result to delete and click Delete. The Delete Test Result window appears.

Click OK to permanently delete the selected test results.
Search for Test Results

The **BatteryStore** database may contain hundreds, or even thousands of test results. The **Search** section of the **Test Results** window lets you search for specific test results.

To search for results based on the battery manufacturer’s name, the battery’s model, or by the test result (good, fair, poor, or low battery), click the DOWN ARROW in the appropriate field and select the criteria.

To search for results based on a date, deselect the **All** check box and then click the DOWN ARROW in the **From** field. Next, click the DOWN ARROW in the **To** field and select the ending date.

Click **Apply** to search for the test results.

Sort the Test Results

To sort the test results, click the **Results** menu item. The **Test Results** window appears.

To sort the test results, click the column header. The test results are sorted in ascending order. Click the column header a second time to reverse the sort order.
View a Test Summary Report

To view a summary of test results, click the Results menu item, then click the Summary button. The Report Summary window appears.

The Report Summary window shows a breakdown of all the tests that were performed.

NOTE

The Report Summary will only display test results that are active in the test results window. For instance, to view the Results Summary for a specific Battery Manufacturer or for a specific time, apply the Search tools (Search for Test Results section) to modify the list of test results.

View different Result summaries by clicking the DOWN ARROW in the Result Type field and selecting between All, QuickSort, Charge, and Cycle.
Section 4: Configure BatteryStore™ Options

BatteryStore Options

The information in the Site Information Setup window appears in Test reports and is the default information that appears in the C5100 Setup window.

To configure BatteryStore’s options, click the Options menu item. The BatteryStore Options window appears.

The General tab contains Site Information, Printer Setup, and Report Template option settings. The Database tab contains Battery Models and Maintenance option settings. Click the appropriate tab to see the list of options.
Site Information Setup

BatteryStore can save customer site information. For each site, BatteryStore saves the site ID, company name, address, and contact information.

To manage information sites, click the Database tab and then click the Site Information menu item. The Site Information Setup window appears.

The default customer site’s information appears in the Site Information Setup window. If required, type new information about the customer’s site in the appropriate fields and click OK to save the information.

Create New Site Information

To create new site information setup, click New. A blank Site Information Setup window appears.
Type the information in the appropriate fields for the new customer site. Click OK to save the information.

**View Site Information**

To view information about a specific site, click Select Site. The Select Site Information window appears.

![Select Site Information Window]

The Select Site Information window lists the sites in the database. Select the site to view and click OK. The site’s information appears in the Site Information Setup window.

To delete a site, select the site and click Delete.

**Export Site Information**

Information about each site can be exported to a Site Information file. To export the site information, click Export. The Save As window appears.

![Export Site Information Window]

Type a name for the site information file in the File name field and click Save. The site information is saved to the file in (.xml) format.
Import Site Information

Information about sites can be imported into BatteryStore from a Battery Customer Site (.xml) file. To import the site information, click Import. The Open window appears.

Locate the text file that contains the site information and click Open. The site information is imported into BatteryStore’s site database.

Printer Setup

To configure printer setup, click the Printer Setup menu item under the General tab. The Printer Setup window appears.

In the PC Printing Options section of the Printer Setup window, select the printer to use by clicking Change. The Print window appears.
Select the appropriate printer BatteryStore will use to print test reports and click OK.

Click the DOWN ARROW in the Print Mode field and select the printing mode. Select the Manual option to require the user to click Print on the Test page to manually print the test report when the battery test is completed; select the Auto option to print the test report automatically when the battery test is completed.

In the Default Printer section of the Printer Setup window, select the C5100 Printer or the PC Printer option to select the printer that BatteryStore will use to print.

Test Report Template

To specify the fields that will appear on printed test reports, click the General tab and then click Report Template. The Report Template window appears.

By default, all field names are automatically selected. Clear the check box next to a field’s name to exclude that field from the report. Select the check box next to the field’s name to include
that field in the report. To select all field names, select the
Select/deselect all check box; to remove all field names, deselect
the Select/deselect all check box.

To move the position of a field up or down in the report, click
the field name and then click Move Up or Move Down. This
sets the order that the fields will appear in reports using this
template.

When you have finished selecting the fields for the report
template, click OK to save the template.

To print a company logo on the report, click Browse. The
Select Report Logo window appears.

Logo files can be JPG, BMP, or GIF files. Navigate to the folder
that contains the logo file, select the file, and click Open. The
logo file’s image appears in the Report Logo section of the
Report Template window.

When you have finished selecting the options for the report
template, click OK to save the template.
Section 5: C5100 Setup

C5100 Setup

The C5100 Setup window is used for C5100 receipt printing and firmware upgrades. The information in the C5100 Setup window is used when printing receipts in Standalone Mode.

To configure the receipt printer information, click the C5100 Setup menu item. The C5100 Setup window appears.

In the Equipment ID field, type an identification number to associate with the selected C5100.

A printer can be connected to the C5100 to print 2 ¼” receipts. Click the DOWN ARROW in the Print Mode field and select the printer option, as follows:
- **Disable**: A printer is not connected to the C5100 or the printer will not be used.

- **Manual**: When the battery test is completed, click **Print** on the Test page to manually print the test receipt.

- **Auto**: When the battery test is completed, the test receipt is automatically printed. Additional receipts can be printed by clicking the **Print** button.

Click **Set** to save the **Print Mode** setting.

In the **C5100 Printer Setup** section of the **C5100 Setup** window, the **Site Information** window under **Options** should be filled out first as this information is automatically transferred to the **C5100 Setup** window by default. Click **Update** to save the information to the C5100.

The date and time displays the PC time and is automatically sent to the C5100 for printing.

### Adapter Q-Codes Setup

Click **Setup** to read and manipulate the Q-Codes from the battery adapter installed in the connected C5100.

Note that an Asterisk (*) in front of a row indicates that the row has been modified.

- **Retrieve**: Clicking this button reads the Q-Codes from the adapter currently installed in the C5100.

- **Update**: Clicking this button saves the Q-Codes to the adapter currently installed in the C5100.
- **Move Up**: Clicking this button moves the selected Q-Code up one line in the list.
- **Move Down**: Clicking this button moves the selected Q-Code down one line in the list.
- **Delete**: Clicking this button removes the selected Q-Code from the list.
- **Export**: Clicking this button exports the Adapter Q-Codes to a file.
- **Import**: Clicking this button imports the Adapter Q-Codes from a file.
- **Close**: Clicking this button exits Adapter Q-Codes Setup.

**Firmware Update**

The *FW Version* field displays the version of the firmware installed in the connected C5100.

**Note**: BatteryStore identifies if your C5100 firmware is out of date (see figure below) during a connection. Update the C5100 firmware to ensure correct operation of BatteryStore.

Select the update button. Follow the Firmware Utility directions.

**WARNING**

Do not remove the C5100 battery adapter while the C5100 is running a test or updating the firmware.
Section 6: Update and Backup the Battery Models Database

Battery Models Update

To Update the Battery Models database:

1. Save the .CFG database file to your PC. The .CFG file is found on the Cadex website, under Product Support.

2. In the Options menu click the Battery Models menu item. The Battery Models Update window appears.

3. To select the file that contains the battery models database file, click Browse. The Select Battery Models Configuration File window appears.
4. Select the configuration file (configuration files have a file extension .CFG) and click **Open**.

   To add battery models that do not exist in the database, select the *Add new models only* option; to add battery models that do not exist in the database and to overwrite existing models, select the *Add new models and overwrite existing models* option. Click **Update**.

5. The **Update Battery Models** window appears.

   Click **OK** to update the database or **Cancel** to return to the **Battery Models Update** window.
A progress bar appears to indicate the update process.

The **Battery Models Updated** window appears, showing the number of battery models that were updated and the number of battery models that were added.

6. Click **OK** to return to the **Battery Models Update** window. Next, click **OK** return to **BatteryStore**’s active window.
Backup the Battery Models Database

BatteryStore can automatically backup your battery models database. To specify the frequency of the backup procedure, click the Options -> Maintenance. The Database Maintenance window appears.

The backup copy of the battery models database is stored by default in the C:\Documents and Settings\All Users\Application Data\Cadex\BatteryStore folder. To change the location of the backup file, click Browse and choose a different folder.

Click the UP or DOWN ARROW in the Frequency field to select how many days should pass before the backup procedure is executed.

Click OK to save your maintenance settings.